Why application does not work on my Android phone?


The most recent version of OBDeleven app is compatible with Android 5.0 and above.

To ensure faster development of new features, security, and compliance with the highest quality standards we are constantly updating the software.  After last update OBDeleven application is not compatible with the Android version before 5.0 and do not allow connection to the vehicle.